#1 2020-01-15 04:46:45

snackish
Member
Registered: 2019-12-12
Posts: 3

FIPS mode initialized

I am getting this error with the datacenter version (I tried with 1.0.1.3 and 1.1.0.3). I see you mention that you fixed it in the Pro version(https://33hops.com/xsibackup-most-common-issues.html). Please let me know if this is a known issue with the datacenter version too.

./xsibackup --backup "VMs(RUNNING)" root@X.X.X.X:22:/backups --compression=yes --rotate=30 --html-template=003 --mail-to=admins@domain.com --use-smtp=3 --subject="running on HOST"
-----------------------------------------------------------------------------------------------------------
|---------------------------------------------------------------------------------|
||-------------------------------------------------------------------------------||
|||   (c)XSIBackup-Datacenter 1.1.0.3: Backup & Replication Software             |||
|||   (c)33HOPS, Sistemas de Informacion y Redes, S.L. | All Rights Reserved    |||
||-------------------------------------------------------------------------------||
|---------------------------------------------------------------------------------|
                   (c)Daniel J. Garcia Fidalgo | info@33hops.com
|---------------------------------------------------------------------------------|
System Information: ESXi, Kernel 6 Major 7 Minor 0 Patch 0
-----------------------------------------------------------------------------------------------------------
License: xxxxxxxxxxxxxxxxxxxx
-----------------------------------------------------------------------------------------------------------
SSH: FIPS mode initializedTue Jan 14 22:54:24 EST 2020
-----------------------------------------------------------------------------------------------------------
2020-01-15T04:44:00 | Error code 1581 at file xsibackup.c, line 1581
Error description: cannot access SSH server at root@X.X.X.X:22, response was: FIPS mode initializedlinux
-----------------------------------------------------------------------------------------------------------
Removed /tmp/xsi dir     OK
-----------------------------------------------------------------------------------------------------------
Unlocked backup          OK
-----------------------------------------------------------------------------------------------------------
Removed PID              OK
-----------------------------------------------------------------------------------------------------------

NOTE: with version 1.0.1.3 the line error was line 1440.

On its own ssh works using the ssh key that I copied over:

ssh -i xsibackup_id_rsa X.X.X.X
FIPS mode initialized
Linux HOST

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Jan 14 20:37:03 2020 from X.X.X.X
root@HOST:#

I confirmed no firewall, executable or version issues issues and tested with both older Debian and newer Ubuntu as remote IP machines and I am getting the same issue. I have tried with adding xsibackup to /usr/bin as well as having it in a separate directory and using --remote-path with no luck.

Please let me know if I am missing anything.

Thank you.

Offline

#2 2020-01-15 18:36:19

admin
Administrator
Registered: 2017-04-21
Posts: 1,302

Re: FIPS mode initialized

We just re-tested current trial version with no issue

|---------------------------------------------------------------------------------|
||-------------------------------------------------------------------------------||
|||   (c)XSIBackup-Datacenter 1.1.0.3: Backup & Replication Software            |||
|||   (c)33HOPS, Sistemas de Informacion y Redes, S.L. | All Rights Reserved    |||
||-------------------------------------------------------------------------------||
|---------------------------------------------------------------------------------|
                   (c)Daniel J. Garcia Fidalgo | info@33hops.com
|---------------------------------------------------------------------------------|
System Information: ESXi, Kernel 6 Major 7 Minor 0 Patch 0
-----------------------------------------------------------------------------------------------------------
License: unlicensed trial version
-----------------------------------------------------------------------------------------------------------
SSH: Wed Jan 15 19:51:14 UTC 2020
-----------------------------------------------------------------------------------------------------------
Remote system: vmkernel
-----------------------------------------------------------------------------------------------------------
PID: 2099656, Running job as: root
-----------------------------------------------------------------------------------------------------------
(c)XSIBackup-Datacenter replicating data to /vmfs/volumes/backup4/DATACENTER-BACKUP-1M
-----------------------------------------------------------------------------------------------------------
New backup/replica: Ubuntu02 | folder
-----------------------------------------------------------------------------------------------------------
Backup start date: 2020-01-15 18:33:33
-----------------------------------------------------------------------------------------------------------
2020-01-15 18:33:33 | Backing up 7 files, total size is 35433495354
-----------------------------------------------------------------------------------------------------------
    NUMBER                                                         FILE            SIZE       PROGRESS
-----------------------------------------------------------------------------------------------------------
     1/7                                                  Ubuntu02.vmx         2.89 KB | Done   0.00%
-----------------------------------------------------------------------------------------------------------
     2/7                                            Ubuntu02-flat.vmdk        33.00 GB | Done   0.00%
-----------------------------------------------------------------------------------------------------------
     3/7                                                Ubuntu02.nvram         8.48 KB | Done 100.00%%
-----------------------------------------------------------------------------------------------------------
     4/7                                                 Ubuntu02.vmsd        45.00 B  | Done 100.00%
-----------------------------------------------------------------------------------------------------------
     5/7                                                 Ubuntu02.vmdk       496.00 B  | Done 100.00%
-----------------------------------------------------------------------------------------------------------
     6/7                                              Ubuntu02-aux.xml        13.00 B  | Done 100.00%
-----------------------------------------------------------------------------------------------------------
     7/7                                              Ubuntu02.vmx.tmp         2.89 KB | Done 100.00%
-----------------------------------------------------------------------------------------------------------
Total size:             33792 MB                                                        | Done 100.00%
-----------------------------------------------------------------------------------------------------------
Backup end date: 2020-01-15 18:34:09
-----------------------------------------------------------------------------------------------------------
Time taken:       36 sec.
-----------------------------------------------------------------------------------------------------------
Total time:       36 sec.
-----------------------------------------------------------------------------------------------------------
Full file speed:                                                                           938.67 mb/s
-----------------------------------------------------------------------------------------------------------
Real data speed:                                                                             1.01 mb/s
-----------------------------------------------------------------------------------------------------------
Item backup completed
-----------------------------------------------------------------------------------------------------------
Data processing completed successfully
-----------------------------------------------------------------------------------------------------------
Removed /tmp/xsi dir     OK
-----------------------------------------------------------------------------------------------------------
Unlocked backup          OK
-----------------------------------------------------------------------------------------------------------
SSH session was closed   OK
-----------------------------------------------------------------------------------------------------------
Removed PID              OK
-----------------------------------------------------------------------------------------------------------

Depending on the Linux distro you are using as a target, and most important: the OpenSSH version it incorporates, you may need to tweak some things. If you want to keep things easy, just use an ESXi host as a target and mount some Linux via NFS.

The abobe test was made to another ESXi server, we'll try to reproduce your error and reach you back.

UPDATE:

Well, your problem is simple, yet you will need to find out a way to silent your excesively verbose Linux system and we'll need to find a solution to pave your way as much as we can.

The thing is that (c)XSIBackup-DC probes your remote system to know what kind of system it's talking to. As your remote Linux OpenSSH server just can't keep its mouth shut even in the most intimate moments, it just spits the extremely annoying "FIPS mode initialized" message in a quite autistic manner, thus breaking the expected answer and making (c)XSIBackup-DC return an error.

We'll try to prevent this by keeping the SSH tunnel quiet in the probe and eventually release the fix as 1.1.0.4

Thank you for using (c)XSIBackup

Offline

#3 2020-01-16 01:59:52

snackish
Member
Registered: 2019-12-12
Posts: 3

Re: FIPS mode initialized

Thank you. That was it. I added the following on the ESXi host:

[root@Host:] cat ~/.ssh/config
Host *
        LogLevel QUIET

That fixed the issue and the backups now seem to be running. I did not want to use NFS, as in my previous forum post (2019-12-12) I was having issues with using NFS off our zfs based NAS. I am now trying iSCSI off that NAS to a linux machine, therefore I did not want to add the extra protocol in between.

Thanks again.

Offline

#4 2020-01-16 10:42:21

admin
Administrator
Registered: 2017-04-21
Posts: 1,302

Re: FIPS mode initialized

Great!, we'll evaluate the possibility to add that quiet flag to the inner subprocess so that you don't have to worry about that.
Let's hope that developers at OpenSSH take it easy from now on, they have run a kind of crazy in regards to some type of messages.

Offline

Board footer