#1 2020-01-03 05:24:30

kcrouch@miningsystems.com
Member
From: Thornton
Registered: 2019-11-19
Posts: 10
Website

Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

Hi,

I am successfully running xsibackup 11.2.2 on ESXi 5.1.0 but I am trying to upgrade to 11.2.14 or 11.2.15 to install a fix you released for me in 11.2.14. But under ESXi 5.1, I get the errors shown below when I try to run xsibackup either straight after install or later from the command line. Please note that it runs fine on my other cluster running ESXi 6.0.0.

The software has been installed and permissions were applied
-----------------------------------------------------
Do you want to execute (c)XSIBackup now (yes/no): yes
-----------------------------------------------------
/scratch/XSI/XSIBackup-Pro/xsibackup: line 10: writeout: not found
/scratch/XSI/XSIBackup-Pro/xsibackup: line 10: writeout: not found
/scratch/XSI/XSIBackup-Pro/xsibackup: line 10: writeout: not found
touch: /scratch/XSI/XSIBackup-Pro/.ERR-: No such file or directory
touch: /scratch/XSI/XSIBackup-Pro/.ERR-: No such file or directory
touch: /scratch/XSI/XSIBackup-Pro/.ERR-: No such file or directory
touch: /scratch/XSI/XSIBackup-Pro/.ERR-: No such file or directory

I end up with a heap of files with names like shown below.
/vmfs/volumes/54a9c48e-14faed07-0e64-00215e5232d0/XSI/XSIBackup-Pro # ls
ERR-~1                ERR-~133              ERR-~168              ERR-~44               ERR-~79
ERR-~10               ERR-~134              ERR-~169              ERR-~45               ERR-~8
ERR-~100              ERR-~135              ERR-~17               ERR-~46               ERR-~80
ERR-~101              ERR-~136              ERR-~170              ERR-~47               ERR-~81
ERR-~102              ERR-~137              ERR-~171              ERR-~48               ERR-~82
ERR-~103   


Thank you,
Kelly.

Offline

#2 2020-01-05 12:00:09

admin
Administrator
Registered: 2017-04-21
Posts: 1,385

Re: Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

You are somehow missing the src/functions file. Please, make sure that you have that file there. Make the whole src folder executable in case you don't get it to work.

Apart from that ESXi 5.1 will soon require to use some older (c)XSIBackup version and also OpenSSH and OpenSSL versions present in 5.1 are incompatible with newer releases.

Offline

#3 2020-01-05 22:00:33

kcrouch@miningsystems.com
Member
From: Thornton
Registered: 2019-11-19
Posts: 10
Website

Re: Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

Hi,

I am not missing the src/functions file and it and the src directory are executable. I have installed it on 4 different 5.1 servers, all with the same result. I have tried copying the directories from a working 6.0 server but with the same result.

ls -ld src/vmfs/volumes/54a9c48e-14faed07-0e64-00215e5232d0/XSI/XSIBackup-Pro # ls -ld src
drwxr-xr-x    1 root     root             8 Jan  5 21:49 src

/vmfs/volumes/54a9c48e-14faed07-0e64-00215e5232d0/XSI/XSIBackup-Pro # ls -l src
-rwx------    1 root     root           367 Jan  5 21:49 api
-rwx------    1 root     root          1171 Jan  5 21:49 cron-init
-rwx------    1 root     root         39965 Jan  5 21:49 functions
-rwx------    1 root     root          4131 Jan  5 21:49 instcron
-rwx------    1 root     root          2044 Jan  5 21:49 mapblocks
-rwx------    1 root     root         48818 Jan  5 21:49 onediff
drwxr-xr-x    1 root     root             8 Jan  5 21:49 pro
-rwx------    1 root     root         13515 Jan  5 21:49 sendmail
-rwx------    1 root     root           171 Jan  5 21:49 version
-rwx------    1 root     root         48690 Jan  5 21:49 xsitools

Thanks,
Kelly.

Offline

#4 2020-01-06 09:36:45

admin
Administrator
Registered: 2017-04-21
Posts: 1,385

Re: Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

We will revise functionality in ESXi 5.1, nonetheless, as said, you may need to use some older release. The error you are getting is very gross, the main module is not able to find the writeout function residing in the functions file, which is used all over xsibackup main module and the rest too.

The functions file is an include in the xsibackup main module, thus the only possibility that you get that error is that src/functions is not found, way too weird unless we have hit some incompatibility with that ESXi build.

The easiest thing you can do is to use some older XSIBackup release which is known to work well on ESXi 5.1, like 11.1.10. We will try to keep backward compatibilty as much as possible, but 5.5 is the oldest ESXi release we are active and extensively testing new (c)XSIBackup-Pro releases.

Contact support to ask for an old release in case you don't have it.

Offline

#5 2020-01-06 10:43:35

admin
Administrator
Registered: 2017-04-21
Posts: 1,385

Re: Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

We have confirmed that some busybox components in ESXi 5.1 are not compatible with some newer releases. OpenSSL per instance outputs data in a different format. We'll try to work this around to offer a widely compatible version as 11.2.16, contact support if you need some help in the meanwhile.

UPDATE:

Seems there will be no problem to fix backward compatibility to ESXi 5.1, the fix will be available soon, as said, should you need some support in the meanwhile, contact us.

UPDATE:

The fix has already been published as 11.2.16

Offline

#6 2020-01-09 03:40:14

kcrouch@miningsystems.com
Member
From: Thornton
Registered: 2019-11-19
Posts: 10
Website

Re: Can't run XSIBackup 11.2.14 or 11.2.15 on ESXi 5.1

Thanks very much. I will try it soon and let you know.

Offline

Board footer