©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software

You are not logged in.

#1 2019-11-19 05:24:47

Registered: 2019-11-19
Posts: 1

Could not get snapshot information: Dictionary problem.

I've been using xsibackup and xsibackup-pro for 4-5 years already and no bigger problems with backing up VM's over WAN with rsync. Now I've moved over to xsibackup-dc and I'm pleased to see that it is significantly faster.

But now I have a lot of problems with replication over WAN. If I try to test the replicated VM at the target, I will get an error: Could not get snapshot information: Dictionary problem. This is related to the snapshots and the source VM doesnt have any snapshot before replication. After replication I can see from the xsibackup log that:

*** Snapshot was removed ***

but it exists at the target. The replicating takes time because the VM's size is 700Gb. At the target system I can find the SRV2-Snapshot523.vmsn and SRV2.vmsd which has the info about the Snapshot523.

So what can I do? I've started from the beginning. Unregistered the VM from the target. Deleted everything from target directory and done the 1st replicating with xsibackup-dc. After this I registered the VM again and the same error. Its strange that ESXi (6.5.0 U2) GUI doesn't show any info about this snapshot.

I am no expert with ESXi, but I deleted manually the snapshot from the target directory and made sure that the .vmsd file is identical at the source and at the target. Then I don't get this Dictionary problem error, but in this case the W2012 refuses to start. I've got similar problems many times with smaller 40Gb-80Gb replicated VM's to the same target, but sometimes the replicating is succesfull. No problem.

I don't understand what is causing this. Am I doing something totally wrong?


#2 2019-11-19 17:31:45

Registered: 2017-04-21
Posts: 2,055

Re: Could not get snapshot information: Dictionary problem.

First of all, please take into account that if you modify or switch-on the remote replica the remote seed will not be valid any more. This is explained in big red letters in the manual. There are ways to work this around, but I won't get into further details by now as the problem you are talking about has to do with snapshots and the workaround is related to them too.

The replica process makes a copy of the .vmx file before replicating the VM to later use it to point to the disks or snapshots the .vmx file was originally pointing at before actually performing any replica. So, you could have a VM with a number of snapshots and replicate it as is, (c)XSIBackup-DC will make a copy of the .vmx file, then take a snapshot to free all files below it, copy all non-opened files to the target along with the .vmx file previous to the snapshot and then delete the snapshot.

So you always end with a remote copy that has a replica of what you had at the local end pointing at exactly the same disks, whether they are .vmdk files or snapshot files.

Windows VMs are affected by a bug which has not been solved so far neither by VMWare nor MS, this is just part of their particular war. This bug duplicates snapshot files when the Windows VM is quiesced (we don't know if this is your case). If you try to quiesce one of the OSs affected you will most likely be transferring only one of the snapshot files as the other one will remain open by the hypervisor. This is not a big concern, you just have to edit the .vmx file and change the disks it points to to make them be the base .vmdk files which in turn point to the -flat.vmdk files.

You can contact support so that we try to reproduce your environment.


Board footer