©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software

You are not logged in.

#1 2019-07-14 09:33:33

From: Munich
Registered: 2019-07-08
Posts: 106

Snapshot created in ESXi, but xsibackup reports error DIFCRES1


I run xsibackup with backup-prog=onediff, backup-how=hot and snapshot=includememory,doquiesce over multiple virtual machines. Generally, it works fine, but for one virtual machine (a Windows server), the xsibackup log file reports:

2019-07-14T08:51:47|  [winserver] info: VMWare Tools detected, taking snapshot QUIESCED(true)...
2019-07-14T08:51:47|  [winserver] info: round 1
2019-07-14T08:54:05|  [winserver] error DIFCRES1: create snapshot xsibackupdiff (1) failed
2019-07-14T08:54:05|  [winserver] workaround: could not create quiesced snapshot, trying non-quiesced
2019-07-14T08:54:06|  [winserver] warning DIFCRES3: non-quiesced snapshot taken as a workaround measure
2019-07-14T08:54:06|  [winserver] info: snapshot taken, quiescing status:

According to the error message, snapshot xsibackupdiff was not created. I checked ESXi, but found out that the allegedly not created snapshot was there. xsibackupdiff is the only snapshot there, as I started from a clean virtual machine where I had already consolidated all snapshots prior to performing the onediff backup.

The allegedly not created snapshot xsibackupdiff was created 14 July 2019, 10:54:06 +0200. So when I read the timestamps of ESXi and xsibackup correctly (they are both hosted on the same server), the error message from xsibackup appears one second before the snapshot xsibackupdiff was created.

The above log file excerpt concerns already the second try of the same virtual machine. Prior to the second run, I consolidated the snapshots/disks again so that I started from a virtual machine without any snapshot. Nevertheless, I ended up the same way.

The virtual machine is a windows server with the services set according to the post XSIBackup: troubleshooting Windows snapshots in ESXi.

Worth to mention is that the problem only occurs with backup-how=hot. As soon as I switch to backup-how=warm, everything is fine.

Do you have any hints as how to overcome this error? Thank you very much.

Best regards,

Last edited by herrep (2019-07-14 11:23:52)


#2 2019-07-14 15:48:59

Registered: 2017-04-21
Posts: 2,055

Re: Snapshot created in ESXi, but xsibackup reports error DIFCRES1

2019-07-14T08:54:05|  [winserver] error DIFCRES1: create snapshot xsibackupdiff (1) failed
2019-07-14T08:54:05|  [winserver] workaround: could not create quiesced snapshot, trying non-quiesced
2019-07-14T08:54:06|  [winserver] warning DIFCRES3: non-quiesced snapshot taken as a workaround measure

Well, the message states that XSIBackup could not take a quiesced snapshot, so it tried to take a non-quiesced snapshot and succedded to do so. So the snapshot was indeed created as non quiesced, though.

The commented post explains what you need to know: https://33hops.com/troubleshooting-wind … -esxi.html

- You first must find out whether you need quiesced snapshots or not. That will depend on the type of services you are running in your Windows server. Tipically database servers will need quiescing.
- Once you know which services will need quiescing, i.e. some SQL Server instance, read about all the services that you need to install to quiesce it in a VMWare ESXi environment and how they must be configured.
- If after installing your software as suggested by the manufacturer, namely MS, you still receive errors at the quiescing stage, look in the event viewer of the Windows guest for errors recorded at the time the quiescing process was happening. The will throw hints about which particular service or driver did not respond in time to the quiescing request. This might indicate that you need to update your VMWare Tools, tweak some time out or that you are still lacking some something in your Windows server.


Board footer