©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software

You are not logged in.

#1 2017-05-04 17:27:06

Registered: 2017-05-04
Posts: 7

Gmail problem

Hello i need help please where is problem? I can not send
email notifications sad 
Why does gmail fail to connect and send an email? All settings are correct.  Thank you for your answer.
Firewall rule SMTPout-465 added...
[0;31mGMail Module ::: The e-mail server [smtp.gmail.com] is not reachable at port [465][0m
2017-05-04T14:17:22|  Firewall rule SMTPout-465 closed.
2017-05-04T14:17:22|  [0;32mBackup finished[0m
2017-05-04T14:17:22|  [0;36mTip: no chained backups scheduled, set --on-success and/or --on-error arguments to chain a backup[0m


#2 2017-05-04 17:41:38


Re: Gmail problem

The error is self explanatory:

The e-mail server [smtp.gmail.com] is not reachable at port [465]

1 - Some firewall is blocking that port inside or outside your network, it does not neccessary need to be ESXi firewall (which XSIBackup manages automatically).

2 - Please, remember that GMail accounts need to be configured to allow "less secure apps"
GMail Less Secure Apps

Last edited by Daniel (2017-05-04 17:43:20)

#3 2017-05-22 06:58:39

Registered: 2017-05-04
Posts: 7

Re: Gmail problem

Please where exactly do I set it up? So the dany port works and the email has been sent? I have even allowed it here. But it still does not work sad

FluxBB bbcode test


#4 2017-06-19 20:25:46

Registered: 2017-06-19
Posts: 3

Re: Gmail problem

Hi Rado,

I know this is a bit late.. but.. does ESXi have connectivity to the internet? ie. Can you ping from ESXi via the CLI?


#5 2017-07-11 14:29:37

Registered: 2017-05-04
Posts: 7

Re: Gmail problem

Ping is ok. Please help where is PROBLEM?
Hello I have tried another port and the same while I manually add and enable that port on the firewall so after crossing the backup script is again the port turned off I do not know where there may be a problem. Email normally works from the local network but is not blocked. Esx is version 6. Xsibackup version 9.0.2
FluxBB bbcode test
FluxBB bbcode test


#6 2017-07-11 19:53:02

Registered: 2017-04-21
Posts: 2,057

Re: Gmail problem

Hello Rado, your problem is very simple: XSIBackup cannot contact smtp.gmail.com on port 465 because something is blocking the connection. You can believe us or not, determining the cause why this is happening is something you'll have to find.

We are sorry that you are stuck with it, but asking the same again won't modify the answer.


#7 2017-07-24 04:34:02

Registered: 2017-07-24
Posts: 1

Re: Gmail problem

hi Rado,
I did have the same problem as yours, but solved it already.
The root of my problem was in me network's firewall, which is very strict as for incoming so for outgiong packets for every local IP which is not in a 'golden list'. By the time I've done my google search and got here, I completely forgot that esxi host IP is not in 'golden llist' and asumed that the problem is in esxi host itself. As soon as I've discovered that problem, I've made an addition of esxi host IP to my firewall golden list - that's all. I believe that your problem is nearly the same.
Needless to say that ALL of my VMs feel themselves well as for gmail so for every other Internet service - simply because their IPs was already added in that list.

So, what was my steps, which lead me to the solution:
1. [root@vcsa:~] nslookup smtp.gmail.com
nslookup: can't resolve 'smtp.gmail.com'
# means DNS services isn't available for esxi host
2. [root@vcsa:~] nc -z <my router with firewall IP> 53
<empty line>
# means my router doesn't want to reply on port 53 to esxi host
3.  [root@vcsa:~] ping <my router with firewall IP>
PING <my router with firewall IP> (<my router with firewall IP>): 56 data bytes

--- <my router with firewall IP> ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
# means from my router's view esxi host is just an exile
4. I went to my router console and quickly discovered that all packets from esxi host are being rejected with ticking of a corresponding counter. ESXi host IP was added to 'the list' afterwards and I saw totally different replies to the same requests:

[root@vcsa:~] nc -z <my router with firewall IP> 53
Connection to <my router with firewall IP> 53 port [tcp/domain] succeeded!
[root@vcsa:~] nslookup smtp.gmail.com
Server:   <my router with firewall IP>
Address 1: <my router with firewall IP> myrouter name

Name:      smtp.gmail.com
Address 1: 2a00:1450:4010:c0b::6c lo-in-x6c.1e100.net
Address 2: lr-in-f109.1e100.net
Address 3: lr-in-f108.1e100.net

4. And the last, but the most important command is attempt to connect to my precious the required port:
If you'll see the following:
[root@vcsa:~] nc -4z smtp.gmail.com 465
Connection to smtp.gmail.com 465 port [tcp/smtps] succeeded!
# then XSIBackup will send your mail for sure. Same for TLS port:
[root@vcsa:~] nc -4z smtp.gmail.com 587
Connection to smtp.gmail.com 587 port [tcp/submission] succeeded!

Last edited by blakman (2017-07-24 07:53:22)


Board footer