©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2021-07-28 07:23:30

underdpt
Member
Registered: 2018-04-30
Posts: 17

Jobs are saved with wrong executable path

Hello,

I'm configuring two new hosts to backup (thanks for the license offer, btw!) and on both hosts the saved jobs executable path is wrong:

This is what i found on xsibackup.log:

/scratch/XSI/XSIBackup-DC/etc/jobs/001: line 8: /vmfs/volumes/5ad9b7f9-64891fd0-c055-e840f20ae690/XSI/XSIBackup-DC/xsibackup/xsibackup: not found

And the job:

/vmfs/volumes/5ad9b7f9-64891fd0-c055-e840f20ae690/XSI/XSIBackup-DC/xsibackup/xsibackup \
--replica \
"VMs(##REDACTED##)" \
"root@##REDACTED##:22:/vmfs/volumes/Backups/backups_exi2" \
--mail-to=##REDACTED## \
--html-template=001 \
--subject="Backup ESXi 2" \
>> /vmfs/volumes/5ad9b7f9-64891fd0-c055-e840f20ae690/XSI/XSIBackup-DC/var/log/xsibackup.log 2>&1

As you can see, there's an extra "/xsibackup" on the first job line, that i've removed manually.

This is on version 1.5.0.11

Offline

#2 2021-07-28 11:18:20

admin
Administrator
Registered: 2017-04-21
Posts: 1,821

Re: Jobs are saved with wrong executable path

You are refering to the GUI, right?
We haven't detected anyhting similar so far. We'll take a closer look, maybe a combination of actions could result in that spurious string.

Offline

#3 2021-07-29 16:19:42

underdpt
Member
Registered: 2018-04-30
Posts: 17

Re: Jobs are saved with wrong executable path

No, I'm not using the GUI.

What I do is test some backups with the CLI, and once I'm satisfied I simply add the --save-job option to the command.

Offline

#4 2021-07-29 16:25:36

admin
Administrator
Registered: 2017-04-21
Posts: 1,821

Re: Jobs are saved with wrong executable path

OK, thank you for the feedback, we'll check the --save-job argument.

UPDATE:
We already fixed it. It will be available in next release.

Offline

Board footer