©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2021-05-14 23:10:21

herrep
Member
From: Munich
Registered: 2019-07-08
Posts: 77

XSIBackup-DC: No email report sent when xsibackup detects an error

Hi,

As long as XSIBackup-DC does not detect an error during execution of a backup or replica, a report is generated over the performed tasks and sent via email as specified in the related options.  However, I realize that a problem occurring during the backup or replica of one of the VMs results in not sending any email.

For example, when I run xsibackup with option --backup-how=hot and some VMs fail to create a snapshot, then xsibackup will throw an error, but nevertheless continue with the next VM.  At the end, after having processed the last VM, surprisingly no report is sent via email.  Instead, xsibackup.log shows at the position where the email report should have been sent:

-----------------------------------------------------------------------------------------------------------
2021-05-14T21:22:02 | Error code 162 at file signal.c, line 162 | Error description: raised SIGTERM (11) (2) in job, num of errors: 11, check error.log
-----------------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------------------------------
SIGTERM (11) condition was trapped: check logs for more details
-----------------------------------------------------------------------------------------------------------
Cleaning up...

---

The error.log shows:

2021-05-14T20:28:31 | Error code 1039 at file esxi.c, line 1039 | Error description: could not create snapshot in <VM-A>, error: KO
2021-05-14T20:28:39 | Error code 1039 at file esxi.c, line 1039 | Error description: could not create snapshot in <VM B>, error: KO
<Listing of all processed VMs>), error count is: 2
2021-05-14T21:22:02 | Error code 162 at file signal.c, line 162 | Error description: raised SIGTERM (11) (2) in job, num of errors: 11, check error.log

Obviously, the snapshot failures do not even result in an immediate termination of xsibackup.  Nevertheless, after having coped with a snapshot failure in some of the VMs, no email report is generated.

By the way, I wonder why "num of errors" in the above-shown error.log is 11, although the last error count was 2 which is correct as two VMs could not be snapshotted. 11 appears to be the signal SIGTERM (I assume termination), but why should xsibackup terminate right after having processed all VMs despite of some VMs where the snapshotting failed?

Best regards,
Peter

Offline

#2 2021-05-15 10:08:16

admin
Administrator
Registered: 2017-04-21
Posts: 1,821

Re: XSIBackup-DC: No email report sent when xsibackup detects an error

Don't use the --backup-how option if you want to perform hot backups, it's the default behavior.
11 is the received signal number, that is: a SEGFAULT. Which is caused when trying to access a restricted area of memory. It seems that due to the failed snapshot that condition is generated in your case. We should delve into it to at least handle the error in a nicer way and show some hint along with the error.

We have two general design principles considerations that are colliding and entering a contradiction there, which are: always trying to continue, no matter what happens to, at least, copy as much data as possible, with: control errors and show nice and explanatory responses. We should probably just continue to the next VM in case of some errors like a failed snapshot, as trying to continue with the backup process will just lead to undefined behavior.

The e-mail report is not sent due to the program jumping to the uncontrolled error handling function, namely: the program exists abruptly. We will add e-mail reporting to it in future versions.

Offline

Board footer