©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2021-01-14 10:08:54

Evgeny
Member
Registered: 2018-08-16
Posts: 21

Problem with a permission while trying to copy files from datastore

Hello! Faced with a problem using NFS datastore - I have NAS with some shared folders, for example, 'vm'. So I connected this folder as datastore to my ESXi host. And I run backup tasks using XSI-backup-free - as a result there are backup images on this shared folder, it's OK. But If I try to mount folder 'vm' as a network drive in Windows 10 I can only see these images but can't copy/remove/delete any of them. Looks like is a problem with permissions: all the images has been created from ESXi root (owner/group) - how to get them from Windows 10 (from network drive)?

Upd: There is only way to get such images - to use WinSCP. But it's not a good decision...

Last edited by Evgeny (2021-01-14 10:10:04)

Offline

#2 2021-01-14 11:07:37

admin
Administrator
Registered: 2017-04-21
Posts: 1,825

Re: Problem with a permission while trying to copy files from datastore

Your issue has very little to do with (c)XSIBackup. Tweak your permissions until you can do what you want. What about gratting all permissions to the users you want.

Remember that in Windows you have NTFS permissions, but you also have a different set of permissions for the share itself.

Offline

#3 2021-01-14 12:14:22

Evgeny
Member
Registered: 2018-08-16
Posts: 21

Re: Problem with a permission while trying to copy files from datastore

Can you explain more detail please? For example, I have a Windows domain "company.local" and my account is "user". So I provide full rights to NFS shared folder for "user@domain.local". But all the images which XSI backup created before is for "root". So should I manually assign permissions for "user@domain.local" each time?

Offline

Board footer