©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2020-12-31 12:46:59

Rolf
Member
Registered: 2020-03-27
Posts: 15

Version 1.4.2.7 command add-key not working

Hello,
I have two VMWare ESXi Server running and update them to ESXi 7.0.1.
At same time I updated XSIBackup-DC to Version 1.4.2.7
With this configuration the command --add-key brings errors ( see output below )

To find out what could be the problem I installed on one of these Servers the "old" XSIBackup-DC Version 1.4.0.0 and what a surprise, it works.
Can you give me an tipp how to solve this problem? I tried it many times, and I am sure that correct password was given!!

Output of XSIBackup-DC Version 1.4.2.7 with errors: ( below ist output on same server of Version 1.4.0.0)
|---------------------------------------------------------------------------------|
||-------------------------------------------------------------------------------||
|||   (c)XSIBackup-DC 1.4.2.7: Backup & Replication Software                    |||
|||   (c)33HOPS, Sistemas de Informacion y Redes, S.L. | All Rights Reserved    |||
||-------------------------------------------------------------------------------||
|---------------------------------------------------------------------------------|
                   (c)Daniel J. Garcia Fidalgo | info@33hops.com
|---------------------------------------------------------------------------------|
System Information: ESXi, Kernel 7 Major 0 Minor 1 Patch 0
-----------------------------------------------------------------------------------------------------------
License: xxxxxxxxx
-----------------------------------------------------------------------------------------------------------
PID: 1061994, Running job as: root
-----------------------------------------------------------------------------------------------------------
Password:
Key exchange routine
-----------------------------------------------------------------------------------------------------------
This is the routine to exchange keys with other servers
You will be prompted to enter the remote server's password
a number of times. Please do so, this is a one time operation
-----------------------------------------------------------------------------------------------------------
/!\ Remember to enable SSH out in the ESXi firewall
-----------------------------------------------------------------------------------------------------------
Password:
Password:
Password:
Could not determine system type at: 192.168.100.2
response: root@192.         KO
-----------------------------------------------------------------------------------------------------------
Response from 192.168.100.2 was: root@192.168.100.2: permission denied (publickey,keyboard-interactive).
-----------------------------------------------------------------------------------------------------------
can't exchange key /vmfs/volumes/5fe1eb60-e0d36658-f57d-0cc47aaabbdc/xsibackup/xsibackup_id_rsa with: root@192.168.100.2:22
Removed <tmp> dir        OK
-----------------------------------------------------------------------------------------------------------
SSH session was closed   OK
-----------------------------------------------------------------------------------------------------------


Output of XSIBackup-DC Version 1.4.0.0:
|---------------------------------------------------------------------------------|
||-------------------------------------------------------------------------------||
|||   (c)XSIBackup-DC 1.4.0.0: Backup & Replication Software                    |||
|||   (c)33HOPS, Sistemas de Informacion y Redes, S.L. | All Rights Reserved    |||
||-------------------------------------------------------------------------------||
|---------------------------------------------------------------------------------|
                   (c)Daniel J. Garcia Fidalgo | info@33hops.com
|---------------------------------------------------------------------------------|
System Information: ESXi, Kernel 7 Major 0 Minor 1 Patch 0
-----------------------------------------------------------------------------------------------------------
License: xxxxxxx
-----------------------------------------------------------------------------------------------------------
PID: 1061927, Running job as: root
-----------------------------------------------------------------------------------------------------------
Password:
Key exchange routine
-----------------------------------------------------------------------------------------------------------
This is the routine to exchange keys with other servers
You will be prompted to enter the remote server's password
a number of times. Please do so, this is a one time operation
-----------------------------------------------------------------------------------------------------------
/!\ Remember to enable SSH out in the ESXi firewall
-----------------------------------------------------------------------------------------------------------
Password: Password:
Password:
Password:
Can't create config file: No such file or directory
Unknown cipher type 'aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc'


Password:
The remote server is of type: vmkernel                                         OK
-----------------------------------------------------------------------------------------------------------
Let's look for the 'authorized_keys' file there...
-----------------------------------------------------------------------------------------------------------
Password:
Found 'authorized_keys' file at: /etc/ssh/keys-root/authorized_keys            OK
-----------------------------------------------------------------------------------------------------------
Checking if local public key exists at remote file...
-----------------------------------------------------------------------------------------------------------
Password:
Add local public key to root@192.168.100.2:22:/etc/ssh/keys-root/authorized_keys?
-----------------------------------------------------------------------------------------------------------
Password:
Local public key <xsibackup_id_rsa> has been
added to root@192.168.100.2:22:/etc/ssh/keys-root/authorized_keys              OK
-----------------------------------------------------------------------------------------------------------
Remote server successfully linked for user root
-----------------------------------------------------------------------------------------------------------
Removed <tmp> dir        OK
-----------------------------------------------------------------------------------------------------------
SSH session was closed   OK

Offline

#2 2020-12-31 13:10:42

admin
Administrator
Registered: 2017-04-21
Posts: 1,821

Re: Version 1.4.2.7 command add-key not working

There are some thing that we need to fine tune relative to the --add-key argument, next version will include a fix.
It will come out in a few days. To work your issue around:

1 - Use the old version to exchange the keys and then overwrite the xsibackup binary with the latest.
2 - Add the public key (xsibackup_id_rsa.pub) to the remote server's authorized_keys file manually:

cat xsibackup_id_rsa.pub | ssh root@a.b.c.d "cat >> /etc/ssh/keys-root/authorized_keys"

The code snippet above will do it, just substitute the a.b.c.d fake IP address by your remote server's one.

3 - We forgot to mention that the same function in the GUI is working properly, so you just have to use the GUI for adding keys to remote systems, that's a lot easier than the above.

Offline

Board footer