#1 2017-09-11 09:20:48

prehcm
Member
Registered: 2017-09-07
Posts: 7

Unable to send the backup report via email

This is the command I am using, the backup seems to work just fine except there is a problem sending the email. I do not need or want SMTP authentication.

 /vmfs/volumes/datastore1/xsi-dir/xsibackup --backup-point=/vmfs/volumes/datastore1/_backups --backup-type=all --date-dir=yes --mail-from=administrator@mydomain.tld --mail-to=administrator@mydomain.tld --smtp-srv=mail.mydomain.tld --smtp-port=25 --smtp-auth=none --smtp-usr=any --smtp-pwd=any --snapshot=includememory --backup-room=120

XSI backup shows this on the cmd line after the backup:

*************************************************************************
*  ESXi Server configuration backup is only available in XSIBACKUP-PRO  *
*************************************************************************
------------------------------------------------------------------------------------------------------------------------------------
Some warnings were raised
------------------------------------------------------------------------------------------------------------------------------------
Firewall rule SMTPout-25 added...
220 mail.mydomain.tld ESMTP Postfix
250 mail.mydomain.tld
250-mail.mydomain.tld
250-PIPELINING
250-SIZE 52428800
250-ETRN
250-STARTTLS
250-AUTH CRAM-MD5 LOGIN PLAIN DIGEST-MD5
250-AUTH=CRAM-MD5 LOGIN PLAIN DIGEST-MD5
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
250 2.1.0 Ok
250 2.1.5 Ok
503 5.5.0 <DATA>: Data command rejected: Improper use of SMTP command pipelining
Firewall rule SMTPout-25 closed.
Backup finished

my mail server logs:

 Transcript of session follows.

 Out: 220 mail.mydomain.tld ESMTP Postfix
 In:  helo server.myesxi.tld
 Out: 250 mail.mydomain.tld
 In:  ehlo server.myesxi.tld
 Out: 250-mail.mydomain.tld
 Out: 250-PIPELINING
 Out: 250-SIZE 52428800
 Out: 250-ETRN
 Out: 250-STARTTLS
 Out: 250-AUTH CRAM-MD5 LOGIN PLAIN DIGEST-MD5
 Out: 250-AUTH=CRAM-MD5 LOGIN PLAIN DIGEST-MD5
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250 DSN
 In:  MAIL FROM: <administrator@mydomain.tld>
 Out: 250 2.1.0 Ok
 In:  RCPT TO: <administrator@mydomain.tld>
 Out: 250 2.1.5 Ok
 In:  DATA
 Out: 503 5.5.0 <DATA>: Data command rejected: Improper use of SMTP command
     pipelining
 In:  SUBJECT: =?utf-8?Q?=E2=9C=94_XSIBACKUP_no_errors_detected_in_backup_job?=
     | ESXi Backup Report. More OSS at
     http://33hops.com/free-open-source-software.html#xsibackup
 Out: 221 2.7.0 Error: I can break rules, too. Goodbye.


For other details, see the local mail logfile

If I skip these 2 parameters: --smtp-usr=any --smtp-pwd=any XSI Backup has other complaints and told me that if I use --smtp-auth=none I need to also provide these other 2 switches.
Here is the error without those two switches:

Some warnings were raised
------------------------------------------------------------------------------------------------------------------------------------
Error: you must set an --smtp-usr
Error: you must set a password, use any if combined with --smtp-auth=none
iError: cannot determine the e-mail server credentials

Also, if I add this switch to the end of above command, XSI backups starts, then says killed and closes.

 --smart-info=yes

any ideas?

Last edited by prehcm (2017-09-11 09:31:16)

Offline

#2 2017-09-11 14:17:19

roberto
Moderator
Registered: 2017-04-22
Posts: 49

Re: Unable to send the backup report via email

You need to configure your e-mail server to allow pipelining, you probably have some parameter like reject_unauth_pipelining activated somewhere. Use this post as a starting point https://groups.google.com/forum/#!topic … Sd4mp0katY

In any case, if you are not an expert mailmaster, just use any gmail.com, hotmail.com, yahoo.com, etc... account, we have tested this servers with XSIBackup and they are free to use.

Last edited by roberto (2017-09-11 14:17:39)

Offline

#3 2017-09-11 14:31:30

prehcm
Member
Registered: 2017-09-07
Posts: 7

Re: Unable to send the backup report via email

Oh, I see, my mailserver was advertising that it supports pipelining and then I had indeed used smtpd_data_restrictions = reject_unauth_pipelining

thanks for the pointers, I'll sort this out now.

Offline

Board footer