#1 2020-11-02 20:35:25

fabian91
Member
Registered: 2020-11-02
Posts: 4

Problems with incremental backup

Hi,
I've tried to create an incremental backup with oneDiff.

After creating the second backup (first incremental), I get an error:

[dummy] error DIFDELAL: error deleting all snapshots VM [dummy_XSIBAK] Id 31, details: Remove All Snapshots:
Remove all snapshots failed.

If I try to start the backup-vm I'm also getting an error. Even removing the snapshots with the web-ui fails.

The error message while starting this vm:
"Fehler beim Einschalten der virtuellen Maschine dummy_XSIBAK. Dateisystemspezifische Implementierung von LookupAndOpen[file] fehlgeschlagen" - "Failed to start the vm. Filesystem specific implementation LookupAndOpen failed"

cat dummy_0-000002.vmdk gives me the same CID like the Parent-CID.

Can anybody help?

Offline

#2 2020-11-03 17:35:19

admin
Administrator
Registered: 2017-04-21
Posts: 1,390

Re: Problems with incremental backup

(c)XSIBackup tried to delete all snapshots, it requested (c)ESXi to do so through a vim-cmd command

vim-cmd vmsvc/snapshot.removeall

But the command returned an error. This has nothing to do with (c)XSIBackup, but with your set up.

Now the thing is, why did it go wrong?
You have some clues in the error message: "Filesystem specific implementation"
So, first questions I would ask are:
Are your file systems on both ends coherent?
Are you by any chance trying to perform a Onediff differential snapshot operation between incompatible file systems?
Is your VM hosted in a VMFS5 volume and you have tried to exchange a snapshot with a VMFS6 registerd VM, or viceversa?

Offline

#3 2020-11-05 19:10:36

fabian91
Member
Registered: 2020-11-02
Posts: 4

Re: Problems with incremental backup

Thank you so much. The Usb-Storage was vmfs6 and the host fs was vmfs5. I formatted the storage with vmfs5 and it works now.
Thank you smile

Offline

Board footer