#1 2019-01-14 04:45:30

eyes
Member
Registered: 2018-03-13
Posts: 27

Log Error: Permission denied (publickey,keyboard-interactive)

Question #1:

We are getting this error when running a backup on a remote server:

###############################################################################
[J2019-01-14T04:18:37|  ###############################################################################
2019-01-14T04:18:37|     XSIBACKUP-PRO 11.2.2: new execution request                     
2019-01-14T04:18:37|  ###############################################################################
.
2019-01-14T04:24:06|  [XX-82] error: cannot copy VMX file, details: Permission denied (publickey,keyboard-interactive).
2019-01-14T04:24:07|  [XX-82] error: cannot copy VMSD file, details: Permission denied (publickey,keyboard-interactive).

###############################################################################
I thought this was cosmetic, but just noticed not backups are being performed.

Question #2:
Incidentally, when i execute:  >>>Key Exchange For Transparent Communication >>> List Servers Linked To This Host" the program abends and returns to the terminal prompt.

Is this a known problem?

Last edited by eyes (2019-01-14 04:49:27)

Offline

#2 2019-01-14 13:08:53

admin
Administrator
Registered: 2017-04-21
Posts: 1,364

Re: Log Error: Permission denied (publickey,keyboard-interactive)

- ¿Have you previously linked both servers?. If the GUI is existing, run this command in the command line:

./xsibackup --link-srv=1.2.3.4:22

Where 1.2.3.4 is the remote IP and 22 is the default SSH port.
- ¿What type of server are you backing up to?
- Is it ESXi, ¿what version of ESXi?

Offline

#3 2019-01-14 13:37:31

eyes
Member
Registered: 2018-03-13
Posts: 27

Re: Log Error: Permission denied (publickey,keyboard-interactive)

Thanks for the quick reply. The response reads as follows:

###############################################################################
#
#  (c) XSIBACKUP-PRO 11.2.2 | Backup for (c) VMWARE ESXi Hypervisor by 33hops.com
#
###################################################################################

NOTICE: (c) XSIBackup kills any user launched jobs, make sure you don't overlap manual jobs
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
XSIBackup PID:        863549359                                                   r720.xxx.com
Enabling port 22 out in the ESXi firewall...
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
There is already an RSA public key at /vmfs/volumes/PE_R720/xsi-dir/xsibackup_id_rsa.pub. We will use the existing one.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Enter the remote server root password when prompted.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Enter remote systems's password for user root, checking OS type...
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Password:
Password:
The local RSA key has already been added to the authorized_keys file at 192.168.1.27:22.
There is no need to add it again, you should be able to connect with XSIBackup to 192.168.1.27:22 without any password.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Killed
/vmfs/volumes/50ef0839-1edef295-865c-90b11c20794a/xsi-dir #
####################################################################################

Local: exsi 5.5 (192.168.1.150)
Remote: exsi: 6.0.0 (192.168.1.27)

Thanks

Last edited by eyes (2019-01-14 13:38:39)

Offline

#4 2019-01-14 16:18:53

admin
Administrator
Registered: 2017-04-21
Posts: 1,364

Re: Log Error: Permission denied (publickey,keyboard-interactive)

Your remote SSHD server is just refusing your connection using a public key.
Are you using some manufacturer custom build of ESXi?.
Have you fully enabled SSH access on the remote host?

Offline

#5 2019-01-14 16:31:44

eyes
Member
Registered: 2018-03-13
Posts: 27

Re: Log Error: Permission denied (publickey,keyboard-interactive)

Hello

The remote host is manufacturer Dell Inc. ESXi 6.0.0,5572656

SSH is enabled; I can connect via putty without issue.


Thanks

Offline

#6 2019-01-14 16:46:07

admin
Administrator
Registered: 2017-04-21
Posts: 1,364

Re: Log Error: Permission denied (publickey,keyboard-interactive)

We asked whether the remote ESXi system is a manufacturer build or an official ESXi build. We don't support manufacturer builds, as they are not official VMWare releases and frequently contain arbitrary changes. You should always use official VMWare builds.

This doesn't mean that our software will not work with those manufacturer builds, but that it might cause you issues like the one you are having, that would not be caused by an official VMWare controlled build.

Dell's are not among the worst manufacturer releases that we know and we also know of XSIBackup users that use DELL builds, but believe us when we warn about manufacturer builds in general. They are most of the times just commercial traps for ESXi users.

Solution

Your remote system is denying access through the exchanged public key, so:
Login into the remote system and edit the following file:

/etc/ssh/sshd_config

The above is the configuration file for the SSHD service on your remote host.
The line

PermitRootLogin yes

Controls whether root login is permitted or not. Set it to yes.
Check the following line:

PubkeyAuthentication yes

Set the PubkeyAuthentication key to yes

Once you have made those changes parse the configuration file from the command line to see if its syntax is O.K.

/usr/lib/vmware/openssh/bin/sshd -t

The above is general SSH configuration. Your hardware manufacturer's build might have been manipulated not to allow some SSH functions.

Offline

#7 2019-01-18 00:42:07

eyes
Member
Registered: 2018-03-13
Posts: 27

Re: Log Error: Permission denied (publickey,keyboard-interactive)

Thank you!

Offline

Board footer