#1 2018-12-04 17:02:43

taztcs
Member
Registered: 2018-12-04
Posts: 3

Compression Issue

I am using version 11.0.1 (the free one) and it is working for the most part and I have only one issue.  The issue is as follows. When I setup the job for cron, I forgot to change the -backup-prog switch to vmkfstools and it did the backup with xsitools.  I have since switched it in the job, but eveytime I do a backup it gives the following error about compression:

ERROR (XSITCOMP), details Error: /vmfs/volumes/Backups compression yes/no related error

When I did further, it says that the directory is an xsitools repository and that compression needs to be enabled (which is not possible as far as I know). 

Since I will not be using xsitools anymore, how do I change it back to a regular repository?

Offline

#2 2018-12-04 17:49:20

admin
Administrator
Registered: 2017-04-21
Posts: 1,364

Re: Compression Issue

You cannot switch from --backup-prog=XSITools:z to --backup-prog=Vmkfstools without changing the --backup-point to a different path, or you will be trying to overwrite an XSITools repository with Vmkfstools backups.

The solution to your problem is very simple: change the --backup-point argument to some other path or delete the old XSITools repository and reuse the same path.

Offline

#3 2018-12-04 18:12:24

taztcs
Member
Registered: 2018-12-04
Posts: 3

Re: Compression Issue

Thanks for the quick response. That was what I was afraid of.  I have a mix in that directory right now, so I will go with the first option.

Offline

#4 2018-12-07 14:57:16

taztcs
Member
Registered: 2018-12-04
Posts: 3

Re: Compression Issue

For anyone else that has this issue, there is a hidden file called .xsitools in the directory (at least on my CentOS 7 box) that has to be deleted in order for the repository to go away.  Once I removed this file, no more compression error.  This way I did not have to change paths or anything else.

Offline

#5 2018-12-08 12:01:43

admin
Administrator
Registered: 2017-04-21
Posts: 1,364

Re: Compression Issue

You still have mixed content, that is not a very good solution.

Offline

Board footer