#1 2018-10-15 14:07:58

adrianoafonso
Member
Registered: 2018-10-15
Posts: 4
Website

The --backup-point string is a mandatory value

Hello there
After using your awesome solution for a wile, and working like charm, I changed some settings on the jobs/001 file, and after that, it completely stopped working.
I think I'm already not a naive on this matters, but this "bug" is driving me nuts for over a month. I already reinstalled again it today, to have a completely new 001 file, reviewed all the configurations, copy-past just the essential, but every time I test with the ./xsibackup command, he gives me always the error:

###############################################################################
#
#  (c) XSIBACKUP-FREE 11.0.1 | Backup for (c) VMWARE ESXi Hypervisor by 33hops.com
#
###################################################################################

XSIBackup PID:          2351685                                        ML350G6.machine.network
Mon, 15 Oct 2018 13:31:34 +0000                                  IPv4: x.x.x.x/255.255.255.0
VMware ESXi 6.7.0 build-8169922                              (c) Rsync 3.1.0 as opt. dependency
------------------------------------------------------------------------------------------------------------------------------------------------
Backup Id:              unknown                 Intel(R) Xeon(R) CPU           E5606  @ 2.13GHz
------------------------------------------------------------------------------------------------------------------------------------------------
Message: crontab is installed for user root
------------------------------------------------------------------------------------------------------------------------------------------------
ADVICE: no SSD disks, please consider adding an SSD cache disk to improve performance
------------------------------------------------------------------------------------------------------------------------------------------------
sh: rsync: unknown operand
Backup user is: root
------------------------------------------------------------------------------------------------------------------------------------------------
The --backup-point string is a mandatory value
You have to set the variable --backup-type to some of the values described in the help
E-mail Warnings
------------------------------------------------------------------------------------------------------------------------------------------------
The e-mail report will not be sent because of the followig reasons:
The --mail-from string has not been set
The --smtp-srv string has not been set
The --smtp-port string has not been set
The --smtp-usr string has not been set, you need --smtp-usr if --smtp-auth is other than -none-
The --smtp-pwd string has not been set, you need --smtp-pwd if --smtp-auth is other than -none-
------------------------------------------------------------------------------------------------------------------------------------------------
Error JOBSKIP1: the backup job will be skipped because some mandatory values are missing
Getting list of all VMs...
------------------------------------------------------------------------------------------------------------------------------------------------
3      LAMP        [RAIDx] LAMP/LAMP.vmx             debian9_64Guest         vmx-14
4      UNMS        [RAIDx] UNMS/UNMS.vmx             debian9_64Guest         vmx-13

etcetera....


\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

And here is my configuration file (just ommited some volumes information)

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

# This is a backup job file example. It starts with the path to your
# xsibackup file and ends with the redirection to the log file. Please
# do make sure that you keep first and last lines, changing paths to
# match your working environment.

"/vmfs/volumes/RAIDx/xsi-dir/xsibackup" \
--backup-prog=vmkfstools \
--certify-backup=yes \
--backup-point=/vmfs/volumes/RAID-lenovo/ \
--backup-type=Running \
--backup-how=Hot \
#--remote-xsipath=/vmfs/volumes/RAIDx/xsi-dir \
--use-smtp=1 \
--mail-to=myemail@mydomain.com \
--backup-id=001 \
--description="Backup Emterprise VMs" \
#--on-success="backupId->002" \
#--on-error="backupId->002" \
--exec=yes >> "/vmfs/volumes/RAIDx/xsi-dir/var/logs/xsibackup.log"


\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

Can you please give a light, because i'm totally lost. Since I just used the 001 example file that comes from installation, and I just copied the essential, I really don't understand why is not working at all, since, in my point of view, all the configs in the jobs/001 file are correct!

PS: I created a Portuguese How To available here: http://www.adrianoafonso.net/blog/2018/ … ware-esxi/

Offline

#2 2018-10-15 16:23:02

admin
Administrator
Registered: 2017-04-21
Posts: 1,370

Re: The --backup-point string is a mandatory value

First of all thank you for your post in Portuguese, I am sure that many people will find it useful.

What you are trying to accomplish is the simplest use scenario for XSIBackup, It should work without a flaw. Please follow this short guide and reach us back witht he result of every point.

1 - First of all, do make sure that the path you are trying to copy your VMs to does exist.

ls -la /vmfs/volumes/RAID-lenovo/

2 - Use this backup job instead:

"/vmfs/volumes/RAIDx/xsi-dir/xsibackup" \
--backup-prog=vmkfstools \
--backup-point=/vmfs/volumes/RAID-lenovo \
--backup-type=Running \
--backup-how=Hot \
--use-smtp=1 \
--mail-to=myemail@mydomain.com \
--backup-id=001 \
--description="Backup Enterprise VMs" \
--exec=yes >> "/vmfs/volumes/RAIDx/xsi-dir/var/logs/xsibackup.log"

3 - Be careful when cutting and pasting text into a shell window. Some characters may be getting substitued. Some times, the characters being swapped are invisible, i.e. some space, so always paste you text into some text editor, like Notepad++ that allows you to check all characters.

Offline

#3 2018-10-15 16:54:32

adrianoafonso
Member
Registered: 2018-10-15
Posts: 4
Website

Re: The --backup-point string is a mandatory value

Hello there
First of all, you welcome, it's part of our Free Software philosophy, right?
Thanks for your fast answer!

1 - Yep, it list, no problem at all!

2 - Just copy your example, made my modifications (on notepad++, thinking windows notepad might be the problem), pasted to the server via PuTTY, and again, same result:

[root@ML350G6:/vmfs/volumes/RAIDx/xsi-dir] ./xsibackup
###############################################################################
#
#  (c) XSIBACKUP-FREE 11.0.1 | Backup for (c) VMWARE ESXi Hypervisor by 33hops.com
#
###################################################################################

XSIBackup PID:          2361526                                        ML350G6.machine.netork
Mon, 15 Oct 2018 16:38:08 +0000                                  IPv4: x.x.x.x/255.255.255.0
VMware ESXi 6.7.0 build-8169922                              (c) Rsync 3.1.0 as opt. dependency
------------------------------------------------------------------------------------------------------------------------------------------------
Backup Id:              unknown                 Intel(R) Xeon(R) CPU           E5606  @ 2.13GHz
------------------------------------------------------------------------------------------------------------------------------------------------
Message: crontab is installed for user root
------------------------------------------------------------------------------------------------------------------------------------------------
ADVICE: no SSD disks, please consider adding an SSD cache disk to improve performance
------------------------------------------------------------------------------------------------------------------------------------------------
sh: rsync: unknown operand
Backup user is: root
------------------------------------------------------------------------------------------------------------------------------------------------
The --backup-point string is a mandatory value
You have to set the variable --backup-type to some of the values described in the help
E-mail Warnings
------------------------------------------------------------------------------------------------------------------------------------------------

////////////////

Other thing, if I use the the test script, like this, with the same configs:

./xsibackup --backup-point=/vmfs/volumes/RAID-lenovo/ --backup-type=running --mail-from=mymail@domain.com --mail-to=mymail@otherdomain.com --smtp-srv=smtp-mail.domain.com --smtp-port=587 --smtp-usr=mymail@domain.com --smtp-pwd=password --smtp-sec=TLS --exec=yes >> "/vmfs/volumes/RAIDx/xsi-dir/var/logs/xsibackup.log"

It works like charm!!!
Any other ideia?
The bizarre is, it worked in the past...

Offline

#4 2018-10-15 17:04:17

admin
Administrator
Registered: 2017-04-21
Posts: 1,370

Re: The --backup-point string is a mandatory value

We have never come accross such problem, and we have many thousand users sad
I removed the --certify-backup option from the example I posted before, as it's not an option available in the free version.
I also changed everything to lower case and removed all unnecessary options, as in the test script.

"/vmfs/volumes/RAIDx/xsi-dir/xsibackup" \
--backup-prog=vmkfstools \
--backup-point="/vmfs/volumes/RAID-lenovo" \
--backup-type=running \
--use-smtp=1 \
--mail-to=myemail@mydomain.com \
--backup-id=001 \
--description="Backup Enterprise VMs" \
--exec=yes >> "/vmfs/volumes/RAIDx/xsi-dir/var/logs/xsibackup.log"

Try it again and let us know.
This is very weird, I think you have just pasted some out of page code characters.

Offline

#5 2018-10-16 08:13:52

adrianoafonso
Member
Registered: 2018-10-15
Posts: 4
Website

Re: The --backup-point string is a mandatory value

Hello there again....
I'm sorry to give you a new one.... And as I told you, it worked quite fine with the option --backup-prog=XSITools:z \ for over 2 months, but since I had changed to vmkfstools, because I need a full backup every day, he started to not work.

Just tested like this:
- deleted the 001 job file
- copy from here, paste on Putty
- made modifications carefully
- quit, save, run ./xsibackup

Same thing!

But tell me one thing, I think I'm not testing something right, because I'm running always ./xsibackup. I should use ./xsibackup –run-backup=001 , correct? But when I use it, he gives me the following error:

./xsibackup: eval: line 1: –runbackup=001: not found

EDIT>>>>>>>>

It seems that I was not testing right.... after some research, yes, I was using the old version of ./xsibackup –run-backup=001 and not  ./xsibackup --run-backup=001

Now I'm testing right... let me reconfigure the cron, and I'll give you feedback!

Last edited by adrianoafonso (2018-10-16 08:28:29)

Offline

#6 2018-10-16 09:24:38

admin
Administrator
Registered: 2017-04-21
Posts: 1,370

Re: The --backup-point string is a mandatory value

You are mixing concepts, --run-backup=001 will look for a backup job file at xsi-dir/jobs and run it. If the file does not exist you will get that "not found" error.

Something has to be broken or mixed in your XSIBackup install. It's almost impossible that there would be a bug that does not allow you to run the most basic kind of backup job and we, as well as some thousand users, have not noticed for months now.

Offline

#7 2018-10-23 16:50:51

adrianoafonso
Member
Registered: 2018-10-15
Posts: 4
Website

Re: The --backup-point string is a mandatory value

Hi there again
That's what I was trying to tell you, you where right, I was not doing the tests correctly. So, I have no problems right now regarding the xsi-dir/jobs/001. I tested and its ok.

Let me test the cronjobs and ill give you feedback!

Offline

#8 2019-04-26 15:21:06

sebastian.cabrera
Member
From: Uruguay
Registered: 2019-04-26
Posts: 1

Re: The --backup-point string is a mandatory value

Hello people.
I have the same problem. Works fine with all the parameters but does not recognize some parameters via the job/001 file or conf/smtpsrvs.

./xsibackup --run-job=001  - Results: "The --backup-point string is a mandatory value"

./xsibackup --run-job=001  --backup-point=/vmfs/volumes/nas02-bioener/besx1- Results: Backup ok

In both cases, i receive the message:


E-mail Warnings
---------------------------------------------------------------------------------------------------------------------------------------------------
The e-mail report will not be sent because of the followig reasons:
The --mail-from string has not been set
The --smtp-srv string has not been set
The --smtp-port string has not been set
The --smtp-usr string has not been set, you need --smtp-usr if --smtp-auth is other than -none-
The --smtp-pwd string has not been set, you need --smtp-pwd if --smtp-auth is other than -none-


jobs/001:

# This is a backup job file example. It starts with the path to your
# xsibackup file and ends with the redirection to the log file. Please
# do make sure that you keep first and last lines, changing paths to
# match your working environment.

"/vmfs/volumes/system/xsi-dir/xsibackup" \
--backup-prog=XSITools \
--backup-point=/vmfs/volumes/nas02-bioener/besx1 \
--backup-type=running \
--backup-how=hot \
--date-dir=yes \
--use-smtp=1 \
--mail-to="sebastian.cabrera@gmail.com" \
--backup-id=001 \
--description="besx1" \
--on-success="backupId->002" \
--on-error="backupId->002" \
--exec=yes >> "/vmfs/volumes/system/xsi-dir/var/logs/xsibackup.log"

conf/stpsrvs

# [TITLE] = SMTP Server
# You can add as many SMTP servers as you want
# Columns are separated by colons as described below
# One server per line pledging to the following format (please, do note that the server IP or FQDN and port are separated by a colon)
# ORDINAL(integer);--smtp-srv(IP or FQDN):--smtp-port;--mail-from;--smtp-usr;--smtp-pwd;--smtp-auth(none|anystring);--smtp-sec(TLS|anystring);--smtp-delay(0-4 sec)
# Do not parse any --smtp-delay unless you need it 0 is OK, only first 8 fields are mandatory
# Example
1;192.8.200.197:25;info@bioener.com.uy;none;none;none;none;0

Offline

Board footer