#1 2018-07-02 22:52:14

stephenzuluaga
Member
Registered: 2018-07-02
Posts: 1

Questions after doing update & upgrade

I've been running xsi free for about 2 years and I recently purchased pro.

I just installed it via the provided install script and would like to start configuring it to utilise the more efficient features of pro, plus to help me handle the addition of two more esxi hosts.

I'd like to use the configured jobs I have as a baseline to configure the extra pro features from.

How do I confirm where my configured jobs are given that the cron mechanics have changed?
How do I execute the gui?
I've also noticed there is a new directory mentioned "xsi-dir/jobs" and that cron jobs need to be edited there before being updated into the ESXi cron handler. I don't have this directory. When I installed, I didn't get any errors.

I tried to find these answers in the documentation but I wasn't able to, if anyone can send me the links I'll check them out.



Thanks.

---update--

I reverted to my original free version, then upgraded it to the latest free version. Doing this created the jobs folder.

I ran a test with these commands and got an error about email.

./xsibackup --backup-point=/vmfs/volumes/dabba3b4-52c7bcec/XSIBackup-backups --mail-from=user@host.com --mail-to=user@host.com --smtp-srv=servername.lan --smtp-port=25 --smtp-auth=none --smtp-delay=1 --backup-type=custom --backup-vms=server1 --backup-room=1500 --date-dir=yes

sh: bad number
sh: bad number
sh: bad number
Error: you must set an --smtp-usr
Error: you must set a password, use any if combined with --smtp-auth=none
iError: cannot determine the e-mail server credentials
Configure static entries for your SMTP servers in the config/smtpsrvs file or set each SMTP var in the backup job
Killed

The manual says that I don't need to specify an smtp-usr if I have smtp-auth=none, however this error message seems to contradict that.


---update 2----

after doing some more tests I've worked around the SMTP auth issue, I think the documentation needs to be updated to reflect the fact that some of the smtp details are now manatory.

Now I'm just trying to invoke the GUI.

Last edited by stephenzuluaga (2018-07-03 00:31:44)

Offline

Board footer