#1 2018-06-12 16:04:54

sainsuper
Member
Registered: 2017-06-12
Posts: 17

XSIbackup PRO 11 - missing some old options

Hello, i'm testing new version 11 before using on my servers.
i can't find some options like in 10.x.x.x version.
for example, how to exclude disks of vm, or limit backup space (--backup-room), in graphic mode.


i think need to edit manually job in jobs folder adding some extra option, but work old options?

thanks
sainsuper

Last edited by sainsuper (2018-06-12 16:16:45)

Offline

#2 2018-06-12 18:19:28

admin
Administrator
Registered: 2017-04-21
Posts: 1,363

Re: XSIbackup PRO 11 - missing some old options

Version 11.0.0 offers a GUI with which you can manage all main XSIBackup arguments, as new minor versions are launched, we will add some new functionality to the GUI, like disk exclusion management, which will be added on version 11.0.1.

We have not removed anything all functionality is still there. The only thing is that you might need to edit the job file manually to do some things by now, such as excluding disks. Some other tasks, like using bash code snippets to generate backup paths dynamically, will always need to be done by editing the job files.

So, you keep everything you already had, you get some really interesting improvements, like using the ESXi cron directly, thus having full Linux crontab flexibility, or centralized backup chaining on top of the GUI. But you can still use XSIBackup by directly editing the job files or creating your own.

Offline

#3 2018-06-13 17:07:49

bpreston
Member
Registered: 2018-05-15
Posts: 5

Re: XSIbackup PRO 11 - missing some old options

Couple quick comments on version 11:

Watch: The Watch jobs screen has a spelling error ("Iddle").  And the menu option 'cancel' at the bottom of that screen gives the impression that you'll be killing the current job.  If that is its intention it does not work; I think the menu option should say "back" (that goes for many of the menu options--cancel (to me) implies aborting on the current operation, while 'back' means navigate backwards in the menu structure.)  I can see where a CancelJob option would be helpful here (it's always a bit of a pain to cancel a running remote host job.)

Watch: I'm unable to get the incremental (percentage) countup of the backup operation to display properly.  I assume it's a terminal issue; I have it set to ISO-8859-1 but tried most translations and it did not help.

Jobs: Editing a job with a custom list of vms or disks to exclude (entered manually at commandline) whacks off any hosts which are NOT found on the current host connected to.  I'd like it to preserve the list, even if it's not correct for that host.

Functionality:
Yes, I should start my own thread, but:
I'm unable to get backups to work with version 11.0.0.  All attempts at backup fail with 'XSIBACKUP_EXIT_STATUS=0' after it starts the 'synchronizing config files' stage.  Cannot find any logging which is indicating what is failing.  If I take the same commandline from 11 and use it on 10.3.4 (stripping out the --exec-yes option) it works.  What can I do to get better logging to help me figure out what the problem may be?  [the switch "debug-info=yes", I think, only lists debug information in email output.]

Offline

#4 2018-06-14 11:27:40

admin
Administrator
Registered: 2017-04-21
Posts: 1,363

Re: XSIbackup PRO 11 - missing some old options

Thank you for your detailed feedback, we do appreciate it.
We already removed that redundant "d".
You are right in regards to that button, we'll add something that is more self explanatory.
That other suggestion about allowing the job to be killed will be added to the feature request list.

For the GUI we have used dialog library, that works on top of ncurses. Unfortunately it is not able to display \r characters, so it breaks percentage progress. Running jobs through the GUI is a convenient but somehow dirty way of running --run-backup=XXX argument. You should do that from the command line if you want full detailed, scrollabe output on screen.

We'll take that list being wiped as a bug and will make the GUI preserve remote VMs when you edit remote jobs.

I noticed we are talking about remote jobs all the time, so when you say "I'm unable to get backups to work with version 11.0.0", I guess you mean "I'm unable to get remote backups to work with version 11.0.0".

If you just converted some older backup jobs into job files at the xsi-dir/jobs directory, there might be something which needs to be tweaked. Contact support with the full backup job to delve into your issue.

Offline

#5 2018-06-14 13:52:36

bpreston
Member
Registered: 2018-05-15
Posts: 5

Re: XSIbackup PRO 11 - missing some old options

Yes.  Looks like it is remote jobs.  I tried running the same job locally and it starts the backups, but does spit this out during execution:

Syncronizing config files
--------------------------------------------------------------------------------------------------------------------------------------
sh: bad number
sh: bad number
--------------------------------------------------------------------------------------------------------------------------------------
Backing up virtual disks...

I'll continue to investigate what the issue is and contact support if I cannot resolve.

Also, bizarre, but if I resize the console window (using Putty) while a backup is running (on the local host) this occurs.  This may have always been a harmless bug, but I'm baffled as to what could be happening:

Cannot process block 293, error getting hash, will retry. Warning:
Retrying...
471/1639 blocks | Processed 28%

Offline

#6 2018-06-14 18:03:04

admin
Administrator
Registered: 2017-04-21
Posts: 1,363

Re: XSIbackup PRO 11 - missing some old options

This could be due to the remote terminal redirection.
Depending on the OpenSSH version present at ESXi, the ssh client behavior changes slightly, so we will probably end up shipping with our own version of busybox, not only for ssh commands, but to prevent some seldom scattered bugs in different command line utilities.
Locate this line in the xsi-dir/src/pro/host:

eval ssh -tt -4 -o StrictHostKeyChecking=no -i "${PWD}/xsibackup_id_rsa" -o ConnectTimeout=20 -p$srv2 ${defremusr}@$srv1

It should be around line 96.
Default ssh client behavior is to redirect output of remote commands to the current terminal, nevertheless, there exist some options to force this: -t and –tt https://linux.die.net/man/1/ssh
Try to remove those two tees and see if you get the output redirected correctly or use one tee to try to force redirection.

Offline

Board footer