#1 2017-05-24 15:01:55

800response.com
Member
Registered: 2017-05-24
Posts: 2

rsync not found

Hello,
I've recently upgraded from free version to XSIBackup PRO, it seems like rsync backups to ESXi target stopped working with the upgrade.

When I run the following, I get rsync not found errors. Can I get help with this please?

[root@esx1:/vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir] ./xsibackup --backup-point="esx2:22:/vmfs/volumes/das1:F" --backup-type=custom --backup-vms="myvm1" --backup-prog=rsync

...

Mirroring to server esx2 port 22
Checking Rsync exists on the other side...
xsibackup-rsync needs to be copied/updated in the remote server
mkdir: can't create directory '/vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/': Operation not permitted
scp: /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir/bin/xsibackup-rsync: No such file or directory
Done!

...

Info: transfering file [ /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/myvm1/myvm1-Snapshot1.vmsn ]
[adm1ri1pro] error: sh: /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir/bin/xsibackup-rsync: not found
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0]

...

[root@esx1:/vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir] ls -l /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir/bin/xsibackup-rsync
-rwxr-xr-x    1 root     root       1195825 May 18 10:04 /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir/bin/xsibackup-rsync
[root@esx1:/vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir]  /vmfs/volumes/57be0e52-e4fc38bd-94c4-a0369fafcc38/xsi-dir/bin/xsibackup-rsync --version
rsync  version 3.1.0  protocol version 31
Copyright (C) 1996-2013 by Andrew Tridgell, Wayne Davison, and others.
Web site: http://rsync.samba.org/
Capabilities:
    64-bit files, 64-bit inums, 32-bit timestamps, 64-bit long ints,
    socketpairs, hardlinks, symlinks, IPv6, batchfiles, inplace,
    append, ACLs, xattrs, iconv, no symtimes, no prealloc

rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
are welcome to redistribute it under certain conditions.  See the GNU
General Public Licence for details.

Offline

#2 2017-05-24 21:49:41

Daniel
Moderator
Registered: 2017-04-22
Posts: 60

Re: rsync not found

Have you installed all files in the XSIBACKUP-PRO package?, it looks like you simply overwrote the xsibackup file and skipped the bin dir. You must copy all files and folders as they are to the installation dir.

You can use the automated script available here: https://33hops.com/user-access.html
Please, remove any remains from any previous installation, uninstalling the cron file first, to avoid mixing files or duplicating to different paths.

Last edited by Daniel (2017-05-24 23:05:15)

Offline

#3 2017-05-25 14:14:49

800response.com
Member
Registered: 2017-05-24
Posts: 2

Re: rsync not found

That seems to have worked, thank you.

Interesting though the xsi-dir/bin/xsibackup-rsync (the same path it listed in the error) existed and was executable.

Offline

Board footer