#1 2017-11-12 21:56:15

matz
Member
Registered: 2017-06-28
Posts: 29

Remote backup problem

Hello!

I have two esxi box. Primary=esxi 6.0U2 and secondary (backup) = esxi 6.5 dell
I try backup first one to second with backup retention. Xsidiff to remote, then xsibackup locally to xsitools deduplication repo.

On first i have in cron:


"/vmfs/volumes/datastore1/xsi-dir/xsibackup" --time="Mon 19:45|Tue 19:45|Wed 19:45|Thu 19:45|Fri 19:45|Sat 19:45|Sun 19:45" --backup-prog=onediff --backup-point="x:22:/vmfs/volumes/SAS15K" --backup-type=all --mail-from=x --mail-to=x@x.pl --smtp-srv=smtp.gmail.com --smtp-usr=x@gmail.com --smtp-pwd=x --smtp-port=465 --on-success="backupid->02" --on-error="backupid->02"

"/vmfs/volumes/datastore1/xsi-dir/xsibackup" backupid=02 --host=x --backup-prog=xsitools:z --backup-point="/vmfs/volumes/SATA3/xsit-$( date +'%Y-%m')" --backup-type=all --override=xsibakfilter  --check-repo=yes --mail-from=x --mail-to=x --smtp-srv=smtp.gmail.com --smtp-usr=x --smtp-pwd=x --smtp-port=465

First job is always success, but at second I have error:

2017-11-12T21:40:53|  [CHR_XSIBAK] CLXSITO1 error: cat: can't open '/vmfs/volumes/SATA3/xsit-2017-11/.xsitools': No such file or directory
2017-11-12T21:40:53|  sh: bad number
2017-11-12T21:40:53|  cat: can't open '/vmfs/volumes/SATA3/xsit-2017-11/.xsitools': No such file or directory
2017-11-12T21:40:53|  sh: bad number
2017-11-12T21:40:53|  cat: can't open '/vmfs/volumes/SATA3/xsit-2017-11/.xsitools': No such file or directory
2017-11-12T21:40:53|  sh: bad number
2017-11-12T21:41:07|  Excerpt

Last edited by matz (2017-11-12 21:57:30)

Offline

#2 2017-11-13 08:37:10

matz
Member
Registered: 2017-06-28
Posts: 29

Re: Remote backup problem

Renaming datastores to default datastore1 helps.

Offline

#3 2017-11-13 12:08:15

admin
Administrator
Registered: 2017-04-21
Posts: 1,363

Re: Remote backup problem

Well, the message is revealing. XSIBackup can't open the XSITools repository config file at: /vmfs/volumes/SATA3/xsit-2017-11/.xsitools
Is there a "/vmfs/volumes/SATA3" datastore at --host=x?

Offline

#4 2017-11-13 20:32:57

matz
Member
Registered: 2017-06-28
Posts: 29

Re: Remote backup problem

Sure, i have SATA3 and SATA15K. I rename to datastore1 and datastore 2 and now efverything is working.

Offline

#5 2017-11-14 11:23:06

admin
Administrator
Registered: 2017-04-21
Posts: 1,363

Re: Remote backup problem

That doesn't make much sense, XSIBackup can use any datastore as it's backup target.
You must have some previous error. It looks like the XSITools repository hasn't been correctly initialized and the .xsitools file is missing.

Offline

Board footer