©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2021-09-30 16:03:49

herrep
Member
From: Munich
Registered: 2019-07-08
Posts: 77

XSIBackup-DC 1.5.1.1 --replica=cbt with an excluded ctk-disabled disk

Hi,

In my present replication setup, I use options --replica=cbt and --options=R to create a replicated VM that is registered again.

This works with some restrictions as long as all disks assigned to the VM are ctk-enabled. However, I also have VMs which include some independent disks which are even excluded from the replication. As they are excluded, there is no need to enable ctk for them as the respective ctk files would never be used. So I disabled ctk for these indendent disks and used option --exclude to ensure that the data of such disks does not need to be transferred.

As soon as I start replication, I receive the following error message:

2021-09-30T15:49:43 | Error code 149 at file esxi.c, line 149 | Error description: no matching CTK entry for disk: scsi0:1
-------------------------------------------------------------------------------------------------------------
/!\ There aren't any CTK files (-1), run --enable-cbt first, ignoring CBT flag
-------------------------------------------------------------------------------------------------------------

The above finding, i.e. scsi0:1 being not ctk enabled and therefore having no CTK files, is correct. But exactly this disk is excluded from backup. The other disk, scsi0:0 is ctk enabled and a CTK file is available. Unfortunately, --replica=cbt does not seem to support such a scenario where not all disks are ctk enabled although all disks to be transferred are ctk enabled.

Did I miss something or would it be necessary to consider these circumstances properly?

Best regards,
Peter

Offline

#2 2021-09-30 16:47:28

admin
Administrator
Registered: 2017-04-21
Posts: 1,821

Re: XSIBackup-DC 1.5.1.1 --replica=cbt with an excluded ctk-disabled disk

You are right, it's a new feature and it still doesn't support that scenario. Still you should be able to solve it by enabling CBT for the disk to then skip it.

Your problem is that the CBT routine will check that every disk has CBT enabled, even if it's an independent disk or raw mapping device. If you enable CBT for it you will pass that check and if on top of that you exclude it, then the disk will be skipped.

UPDATE:

Even if you enable CBT for all disks and you don't explicitly exclude the independent disk, the backup routine will just skip it for being innaccesible. The only drawback would be to have to manually exclude it from the .vmx file when restoring.

Regards

Offline

Board footer