©XSIBackup-Free: Free Backup Software for ©VMWare ©ESXi

Forum ©XSIBackup: ©VMWare ©ESXi Backup Software


You are not logged in.

#1 2021-09-26 21:49:20

herrep
Member
From: Munich
Registered: 2019-07-08
Posts: 77

XSIBackup-DC 1.5.1.1 --backup=cbt no folder create with remote

Hi,

When using --backup=cbt and specifying an NFS drive (mounted as datastore in ESXi) as backup destination, the repo directory is created.
In fact, the NFS drive is remote, and I can also specify a remote path, as xsibackup is availabkle on the NAS.

As long as I use --replica, the remote path works and missing directories are correctly created.
However, once I switch to --backup=cbt and specifying the same remote path that works with --replica, I receive the following error message:

Performing --backup action
-------------------------------------------------------------------------------------------------------------
ckup/repo-202109': Not a directory
-------------------------------------------------------------------------------------------------------------
2021-09-26T17:27:52 | Error code 3254 at file xsibackup.c, line 3254 | Error description: something went wrong creating the backup folder at: <nas>/backup/repo-202109
-------------------------------------------------------------------------------------------------------------
202109': Not a directory
-------------------------------------------------------------------------------------------------------------
2021-09-26T17:27:53 | Error code 4364 at file common.c, line 4364 | Error description: something went wrong creating the data folder at: <nas>/backup/repo-202109/data, error: Illegal seek
-------------------------------------------------------------------------------------------------------------
o-202109': Not a directory
-------------------------------------------------------------------------------------------------------------
2021-09-26T17:27:54 | Error code 4373 at file common.c, line 4373 | Error description: something went wrong creating the config backup folder at: <nas>/backup/repo-202109/cfgbak, error: Illegal seek
-------------------------------------------------------------------------------------------------------------

In my setup, the same backup drive can be accessed from the ESXi via NFS mount locally or via a remote path.

What I can see is that, when using --backup=cbt and remote path, a file "repo-202109" is created, but not a directory. As already mentioned, when using --replica, the creation of directories works fine, meaningless whether I use the remote path or the local NFS mounted drive as destination. With --backup=cbt, I can only use a local path, not the remote path.

Best regards,
Peter

Offline

Board footer